XeroHost - Global Issues Related to Targeted Attacks on Our Infrastructure (MIAMI) – Incident details

All systems operational

Global Issues Related to Targeted Attacks on Our Infrastructure (MIAMI)

Resolved
Partial outage 30 %
Started 3 days agoLasted 1 day

Affected

Website (xerohost.net)

Operational from 10:10 PM to 10:51 PM

Billing System (billing.xerohost.net)

Operational from 10:10 PM to 10:51 PM

Game Panel (panel.xerohost.net)

Operational from 10:10 PM to 10:51 PM

VPS Panel (vps.xerohost.net)

Operational from 10:10 PM to 10:51 PM

Games Servers: North America - Advanced

Partial outage from 10:10 PM to 10:51 PM

Miami, FL - 1

Partial outage from 10:10 PM to 10:51 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    Our network team has been investigating this issue since 2025-10-24 21:52:40 CEST . We will update as we receive more details.

    The issue occurs frequently, lasting about 60 seconds each time. Our team is working hard to find workarounds and resolve this issue as soon as possible. We greatly appreciate your understanding and patience in the meantime.